Custom Search

SUBSCRIBE

SUBSCRIBE : 300 + Free Video Tutorials Programming (Python, golang, Julia), DevOps

Monday, November 24, 2014

WARNING [neutron.api.extensions] Extension ipam not supported by any of loaded plugins

Fix
===
Extension not loading and seeing WARNING "[neutron.api.extensions] Extension ipam not supported by any of loaded plugins" while starting the "neutron-server". 

* Add the name of the extension in class variable "supported_extension_aliases" in the plugin class

Example:
---------------
class NeutronPluginContrailCoreV2(neutron_plugin_base_v2.NeutronPluginBaseV2,
                                  securitygroup.SecurityGroupPluginBase,
                                  portbindings_base.PortBindingBaseMixin,
                                  external_net.External_net):

    supported_extension_aliases = ["security-group", "router",
                                   "port-security", "binding", "agent",
                                   "quotas", "external-net", "ipam"]



ERROR
======

#sudo python neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/opencontrail/ContrailPlugin.ini

/usr/lib/python2.7/dist-packages/eventlet/hubs/__init__.py:8: UserWarning: Module neutron was already imported from /home/saju/neutron/neutron/__init__.pyc, but /usr/lib/python2.7/dist-packages is being added to sys.path
  import pkg_resources
loc:===> /home/saju/neutron/neutron/__init__.pyc
2014-11-23 12:54:47.984    ERROR [neutron.api.extensions] Extension path 'extensions' doesn't exist!
2014-11-23 12:54:47.987  WARNING [neutron.api.extensions] Extension contrail not supported by any of loaded plugins
2014-11-23 12:54:47.989  WARNING [neutron.api.extensions] Extension ipam not supported by any of loaded plugins
2014-11-23 12:54:47.991  WARNING [neutron.api.extensions] Extension policy not supported by any of loaded plugins
2014-11-23 12:54:47.994  WARNING [neutron.api.extensions] Extension route-table not supported by any of loaded plugins
2014-11-23 12:54:48.0  WARNING [neutron.api.extensions] Extension allowed-address-pairs not supported by any of loaded plugins
2014-11-23 12:54:48.4  WARNING [neutron.api.extensions] Extension dhcp_agent_scheduler not supported by any of loaded plugins
2014-11-23 12:54:48.8  WARNING [neutron.api.extensions] Extension extra_dhcp_opt not supported by any of loaded plugins
2014-11-23 12:54:48.10  WARNING [neutron.api.extensions] Extension extraroute not supported by any of loaded plugins
2014-11-23 12:54:48.21  WARNING [neutron.api.extensions] Extension fwaas not supported by any of loaded plugins
2014-11-23 12:54:48.25  WARNING [neutron.api.extensions] Extension flavor not supported by any of loaded plugins
2014-11-23 12:54:48.31  WARNING [neutron.api.extensions] Extension ext-gw-mode not supported by any of loaded plugins
2014-11-23 12:54:48.35  WARNING [neutron.api.extensions] Extension l3_agent_scheduler not supported by any of loaded plugins
2014-11-23 12:54:48.42  WARNING [neutron.api.extensions] Extension lbaas_agent_scheduler not supported by any of loaded plugins
2014-11-23 12:54:48.52  WARNING [neutron.api.extensions] Extension lbaas not supported by any of loaded plugins
2014-11-23 12:54:48.56  WARNING [neutron.api.extensions] Extension metering not supported by any of loaded plugins
2014-11-23 12:54:48.59  WARNING [neutron.api.extensions] Extension multi-provider not supported by any of loaded plugins
2014-11-23 12:54:48.65  WARNING [neutron.api.extensions] Extension provider not supported by any of loaded plugins
2014-11-23 12:54:48.69  WARNING [neutron.api.extensions] Extension routed-service-insertion not supported by any of loaded plugins
2014-11-23 12:54:48.71  WARNING [neutron.api.extensions] Extension router-service-type not supported by any of loaded plugins
2014-11-23 12:54:48.79  WARNING [neutron.api.extensions] Extension service-type not supported by any of loaded plugins
2014-11-23 12:54:48.85  WARNING [neutron.api.extensions] Extension vpnaas not supported by any of loaded plugins
2014-11-23 12:54:48.163  WARNING [keystoneclient.middleware.auth_token] Configuring auth_uri to point to the public identity endpoint is required; clients may not be able to authenticate against an admin endpoint
2014-11-23 12:54:48.164  WARNING [keystoneclient.middleware.auth_token] signing_dir is not owned by 0










No comments:

Post a Comment